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1 GENERAL

1.1 Scope

This document gives a formal specification of part of the SSQL semantics. Together with [3] it
constitutes deliverable D3 of work package 1a, as given in section 7 of the Secure Database Technical
Proposal, [1].

1.2 Introduction

In the Secure Database Technical Proposal, [1], we stated that we propose to formalise the semantics
of SSQL, supplied initially in Annex 2, SSQL Abstract Machine, to the ITT [4], in a manner suitable
for the required security proof, as outlined in [1]. This involves the specific features of the semantics
which ensure that query processing is secure be clearly separated from the purely functional aspects.
This results in the formalisation of the semantics of SSQL being presented in three main parts:

1. A function hide on the state of the database which returns a sanitised state of the database.
This version of the database does not include any information the existence of which the user
is not cleared to know, nor does it contain the true value of any field which the user is not
cleared to see.

2. The main functionality of SSQL, i.e. how the result of a query is computed from the state of
the database.

3. A function updateState which applies the update determined in (2) to the database.This func-
tion is responsible for capturing the security constraints associated with updates.

This document provides the specification of enough of the functionality of the semantics of SSQL to
enable the state of the abstract machine to be defined. The remainder of the main functionality of
SSQL is specified in [3]. The functions hide and updateState are formalised in [2].

1.3 Terminology

Labelled products with names of the form Xxxx will have labels prefixed by X ; labelled products
with names of the form XxxxYyyy will have labels prefixed by XY . The only exceptions to this will
be in the case where two labelled products would have identical labels, e.g. Data and DirectoryT
will have labels prefixed by Dat and Dir respectively. Constructors for labelled products are
automatically generated by the ProofPower system; names of constructors for labelled products take
the form of the name of the labelled product prefixed by Mk .

2 PRELIMINARIES

The following ProofPower instructions set up the new theory fef004 and set the context for the proof
tools.
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SML

open theory "fef003";

(force delete theory "fef004" handle => ());

new theory"fef004";

push pc "hol";

3 DATA TYPES IN THE STATE

In the following, as well as types we have introduced some constants, which are sets. This is in order
to define invariants on the state of the database. Typically, these invariants are that certain relations
are partial functions, and the partial function operator 7→ is defined on sets. Where possible, the
same name has been used for the type and the constant; otherwise the name of the set is the name
of the type suffixed with S .

The types CHAR, STRING , N and BOOL are already defined in the system.

SML

declare type abbrev("Char",[],p: CHARq);

SML

declare type abbrev("String",[],p: STRINGq);

SML

declare type abbrev("Num",[],p: Nq);

The constant Num is the set of everything of type Num.

HOL Constant

Num : Num P

Num = Universe

SML

declare type abbrev("Bool",[],p: BOOLq);

SML

declare type abbrev("Ide",[],p: Stringq);

The constant Ide is the set of everything of type Ide.

HOL Constant

Ide : Ide P

Ide = Universe
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HOL Labelled Product

Int

I mantissa : Num;

I exponent : Num

HOL Labelled Product

Float

F mantissa : Num;

F exponent : Num

We introduce new types Time, Interval and Code.

SML

new type("Time",0 );

SML

new type("Interval",0 );

SML

new type("Code",0 );

The different ‘sorts’ of errors are modelled as natural numbers.
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HOL Constant

error notCleared tooWide tooTall wrongType

nullValue noSuchColumn ambiguousColumn

ambiguousUpdate mayNotBeComplete

underClassified downGrade classChange

noSuchTable noSuchDirectory

ambiguousEvaluate ambiguousHaving

nonUniformValues nonUniqueValues

noNulls fieldClassOutOfRange

rowClassTooLow accessDenied : Num

error = 1

∧ notCleared = 2

∧ tooWide = 3

∧ tooTall = 4

∧ wrongType = 5

∧ nullValue = 6

∧ noSuchColumn = 7

∧ ambiguousColumn = 8

∧ ambiguousUpdate = 9

∧ mayNotBeComplete = 10

∧ underClassified = 11

∧ downGrade = 12

∧ classChange = 13

∧ noSuchTable = 14

∧ noSuchDirectory = 15

∧ ambiguousEvaluate = 16

∧ ambiguousHaving = 17

∧ nonUniformValues = 18

∧ nonUniqueValues = 19

∧ noNulls = 20

∧ fieldClassOutOfRange = 21

∧ rowClassTooLow = 22

∧ accessDenied = 23

SML

declare type abbrev("Error",[],p: Numq);

The different ‘sorts’ of worth are also modelled as natural numbers.
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HOL Constant

worthless dinary sterling priceless : Num

worthless = 1

∧ dinary = 2

∧ sterling = 3

∧ priceless = 4

SML

declare type abbrev("Worth",[],p: Numq);

Val is declared as a sum type (i.e. binary disjoint union). The ‘types’ void and exception are given
as one-point types.

SML

declare type abbrev("Val",[],

p: ONE + Bool + String + Int + Float + Time + Interval + Code + Class + ONEq);

We give constructors for type Val .

HOL Constant

VoidVal : Val ;

BoolVal : Bool → Val ;

StringVal : String → Val ;

IntVal : Int → Val ;

FloatVal : Float → Val ;

TimeVal : Time → Val ;

IntervalVal : Interval → Val ;

CodeVal : Code → Val ;

ClassVal : Class → Val ;

ExceptionVal : Val

∀ b:Bool ; s:String ; i :Int ; f :Float ; t :Time; n:Interval ; c:Code; cl :Class

• VoidVal = InL One

∧ BoolVal b = InR (InL b)

∧ StringVal s = InR (InR (InL s))

∧ IntVal i = InR (InR (InR (InL i)))

∧ FloatVal f = InR (InR (InR (InR (InL f ))))

∧ TimeVal t = InR (InR (InR (InR (InR (InL t)))))

∧ IntervalVal n = InR (InR (InR (InR (InR (InR (InL n))))))

∧ CodeVal c = InR (InR (InR (InR (InR (InR (InR (InL c)))))))

∧ ClassVal cl = InR (InR (InR (InR (InR (InR (InR (InR (InL cl))))))))

∧ ExceptionVal = InR (InR (InR (InR (InR (InR (InR (InR (InR One))))))))
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HOL Labelled Product

ValuedItem

VI worth : Num;

VI val : Val

The type NullItem is given as a one-point type.

SML

declare type abbrev("NullItem",[],p: ONEq);

declare alias("null",pOneq);

Item is declared as a sum type.

SML

declare type abbrev("Item",[],p: ValuedItem + NullItemq);

We give constructors for type Item.

HOL Constant

ValuedItemItem : ValuedItem → Item;

NullItemItem : NullItem → Item

∀ v :ValuedItem; n:NullItem

• ValuedItemItem v = InL v

∧ NullItemItem n = InR n

HOL Labelled Product

Data

Dat class : Class;

Dat item : Item

The constant DataS is the set of everything of type Data.

HOL Constant

DataS : Data P

DataS = Universe

SML

declare type abbrev("Update",[],p: Item + Class + Dataq);

We need constructor, discriminator and destructor functions for Update.
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HOL Constant

ItemUpdate : Item → Update;

ClassUpdate : Class → Update;

DataUpdate : Data → Update

∀ i :Item; c:Class; d :Data

• ItemUpdate i = InL i

∧ ClassUpdate c = InR (InL c)

∧ DataUpdate d = InR (InR d)

HOL Constant

isItem : Update → Bool ;

isClass : Update → Bool ;

isData : Update → Bool

∀ u:Update

• (isItem u = ∃ i :Item • u = ItemUpdate i)

∧ (isClass u = ∃ c:Class • u = ClassUpdate c)

∧ (isData u = ∃ d :Data • u = DataUpdate d)

HOL Constant

destItem : Update → Item;

destClass : Update → Class;

destData : Update → Data

∀ i :Item; c:Class; d :Data

• destItem (ItemUpdate i) = i

∧ destClass(ClassUpdate c) = c

∧ destData (DataUpdate d) = d

We give monolean, boolean, chars, integer , floating , time, interval and class as elements of one-point
types.

SML

declare alias("monolean",pOneq);

declare alias("boolean",pOneq);

declare alias("chars",pOneq);

declare alias("integer",pOneq);

declare alias("floating",pOneq);

declare alias("time",pOneq);

declare alias("interval",pOneq);

declare alias("class",pOneq);
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SML

declare type abbrev("Type",[],

p: ONE + ONE + ONE + ONE + ONE + ONE + ONE + ONEq);

SML

declare type abbrev("Errors",[],p: Error LISTq);

HOL Labelled Product

ColSpec

CS ide : Ide;

CS posn : Num;

CS dinaryType : Type;

CS sterlingType : Type;

CS nullType : Bool ;

CS default : Data;

CS consGroup : Num;

CS min : Class;

CS max : Class

We have removed Error from the state of the data base and will provide access functions which
return either a data type or an error.

SML

declare type abbrev("Tab",[],p: Ide LISTq);

HOL Labelled Product

Reference

R table : Tab;

R group : Num

HOL Labelled Product

ColCon

CC exist : Class;

CC uniform : Bool ;

CC unique : Bool ;

CC classLimited : Bool ;

CC primary : Bool ;

CC secondary : Bool ;

CC referential : Reference LIST
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The constant ColConS is the set of everything of type ColCon.
HOL Constant

ColConS : ColCon P

ColConS = Universe

HOL Labelled Product

Row

R exist : Class;

R data : Num ↔ Data

The constant RowS is the set of everything of type Row where the data in the row is a partial
function.
HOL Constant

RowS : Row P

RowS = {r | let data = R data r in data ∈ Num 7→ DataS}

HOL Labelled Product

TableSpec

TS class : Class;

TS maxRow : Class;

TS colspecs : ColSpec P;

TS cons : Num ↔ ColCon;

TS rows : Row LIST

The constant TableSpecS is the set of everything of type TableSpec where the column constraints is
a partial function and the rows are members of Rows.
HOL Constant

TableSpecS : TableSpec P

TableSpecS = {ts | let cns = TS cons ts and rows = TS rows ts

in cns ∈ Num 7→ ColConS ∧ ∀ r • r ∈l rows ⇒ r ∈ RowS}

HOL Labelled Product

Directory

Dir tables : Ide ↔ TableSpec;

Dir exist : Class;

Dir class : Class
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The constant DirectoryS is the set of everything of type Directory where the tables are a partial
function from Ide to TableSpecS .

HOL Constant

DirectoryS : Directory P

DirectoryS = {d | Dir tables d ∈ Ide 7→ TableSpecS}

The constant IdeL is the set of everything of type list of Ide.

HOL Constant

IdeL : (Ide LIST )P

IdeL = Universe

The representation type for State : Exp is StateR.

SML

declare type abbrev("StateR",[],p: Ide LIST ↔ Directoryq);

The constant StateS is the set of everything of type StateR which is a partial function from IdeL to
DirectoryS .

HOL Constant

StateS : StateR P

StateS = IdeL 7→ DirectoryS

We define the property required on the representation state.

HOL Constant

isState : StateR → Bool

∀ s • isState s ⇔ s ∈ StateS

We demonstrate that the new type will be non-empty.

SML

push goal([],p∃ s : StateR • isState sq);

a(rewrite tac[get specpisStateq]);

a(∃ tacp{}q);

a(rewrite tac[get specpStateSq, 7→ def ,functional def ,∩ def ,↔ def ]);

Now the new type State : Exp is defined.

SML

val state type def = new type defn(["state type def "],"State",[],pop thm());

We have chosen not to model Result . A Result is either some data or just a classification (when the
user is not cleared to observe the actual value). In effect, we always have something of type Data;
in the case when the user is not cleared to see the value, the value will be Hidden anyway.
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4 FUNCTIONALITY OF THE QUERY PROCESSING

4.1 Auxiliary Functions

General constructor, discriminator and destructor functions for a sum type where one component is
an error or sequence of errors.

HOL Constant

giveVal : ′a → ′a + ′Error ;

giveError : ′Error → ′a + ′Error ;

destVal : ′a + ′Error → ′a;

destError : ′a + ′Error → ′Error ;

isVal : ′a + ′Error → Bool ;

isError : ′a + ′Error → Bool

∀ v ; e; ve

• giveVal v = InL v

∧ giveError e = InR e

∧ destVal (giveVal v) = v

∧ destError(giveError e) = e

∧ (isVal ve = ∃ v1 • ve = giveVal v1 )

∧ (isError ve = ∃ e1 • ve = giveError e1 )

4.2 Type of Effect

The functionality of the semantics of SSQL will be captured by the function processQuery ,described
in section 4.3. This function takes a query, a user’s clearance and a state and returns the result of
the query, i.e., the output to be seen by the user, an update to be applied to the data base and some
error messages. The effect of a query depends on the type of the query. Insertions, deletions and
updates either all succeed or all fail. i.e. any mayNotbeComplete on inner selects result in no change
to the data base.

The ‘effect’ of an insert query is a sequence of relations between column number and data , together
with a full table name. Each element in the sequence will give a new row whose existence classification
is the same as the user’s clearance. Missing columns (i.e. columns that were hidden from the user)
will be supplied with the default data for that column.

SML

declare type abbrev("Insert",[],p: Tab × (Num ↔ Data) LISTq);

The ‘effect’ of a delete query is a full table name and a set of non-negative integers corresponding
to which rows in the table’s sequence of rows are to be deleted. Note, these row positions will be
relative to the hidden state of the database that the user sees, not its actual state.

SML

declare type abbrev("Delete",[],p: Tab × Num Pq);
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The ‘effect’ of an update query is a full table name and a relation from row number to a relation from
column number to actual update. Again, the row positions will be relative to the hidden state of the
database that the user sees, not its actual state. (We use the identifier UpDate because Update has
already been used.)

SML

declare type abbrev("UpDate",[],p: Tab × (Num ↔ (Num ↔ Update))q);

The ‘effect’ of a select query is some data to be returned to the user (in fact, a sequence of sequence
of Data).

SML

declare type abbrev("Select",[],p: Data LIST LISTq);

This gives us the sum type Effect .

SML

declare type abbrev("Effect",[],p: Insert + Delete + UpDate + Selectq);

We give constructor, discriminator and destructor functions for type Effect .

HOL Constant

InsertEffect : Insert → Effect ;

DeleteEffect : Delete → Effect ;

UpdateEffect : UpDate → Effect ;

SelectEffect : Select → Effect

∀ i :Insert ; d :Delete; u:UpDate; s:Select

• InsertEffect i = InL i

∧ DeleteEffect d = InR (InL d)

∧ UpdateEffect u = InR (InR (InL u))

∧ SelectEffect s = InR (InR (InR s))

HOL Constant

isInsert : Effect → Bool ;

isDelete : Effect → Bool ;

isUpdate : Effect → Bool ;

isSelect : Effect → Bool

∀ e :Effect

• (isInsert e = ∃ i :Insert • e = InsertEffect i)

∧ (isDelete e = ∃ d :Delete • e = DeleteEffect d)

∧ (isUpdate e = ∃ u:UpDate • e = UpdateEffect u)

∧ (isSelect e = ∃ s:Select • e = SelectEffect s)
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HOL Constant

destInsert : Effect → Insert ;

destDelete : Effect → Delete;

destUpdate : Effect → UpDate;

destSelect : Effect → Select

∀ i :Insert ; d :Delete; u:UpDate; s:Select

• destInsert(InsertEffect i) = i

∧ destDelete(DeleteEffect d) = d

∧ destUpdate(UpdateEffect u) = u

∧ destSelect(SelectEffect s) = s

We also provide a function that return the table name from an effect; this function will not be applied
to a Select effect.

HOL Constant

tabFromEffect : Effect → Tab

∀ i :Insert ; d :Delete; u:UpDate

• tabFromEffect (InsertEffect i) = Fst i

∧ tabFromEffect (DeleteEffect d) = Fst d

∧ tabFromEffect (UpdateEffect u) = Fst u

4.3 The function processQuery

The functionality of SSQL is modelled with processQuery , specified in [3].

5 AUXILIARY PROOF WORK

For convenience, we provide some consistency proofs will be required by later proof documents.

5.1 Consistency Proof for dominates

We prove the consistency of dominates, lattice bottom, lattice top and lub.

SML

push consistency goalp$dominatesq;

a(cases tacp∀ top bot :Class • top = botq);

(∗ ∗∗∗ Goal "1" ∗∗∗ ∗)

This is the case where Class has only one element:
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SML

a(∃ tacp(λ x y • T ),top,top,(λ x y • x ),(λ x y • x )q);

a(asm rewrite tac[]);

(∗ ∗∗∗ Goal "2" ∗∗∗ ∗)

In this case, top and bot are given to be distinct elements of Class, we take the so-called flat lattice
with top as top, bot as bottom and everything else incomparable (and in between).

SML

a(∃ tacp(

(λ c1 c2 • c1 = top ∨ c2 = bot ∨ c1 = c2 ),

bot ,

top,

(λ c1 c2 • if c1 = top

then top

else if c1 = bot

then c2

else if c2 = c1 ∨ c2 = bot

then c1

else top),

(λ c1 c2 • if c1 = bot

then bot

else if c1 = top

then c2

else if c2 = c1 ∨ c2 = top

then c1

else bot))

q);

a(rewrite tac[] THEN REPEAT strip tac

THEN TRY asm rewrite tac[]

THEN TRY SOLVED T (PC T1 "prop eq" asm prove tac[])

THEN TRY all var elim asm tac);

This produces 11 subgoals but the proof is fairly mechanical:
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SML

(∗ ∗∗∗ Goal "2 .1" ∗∗∗ ∗)

a(all asm ante tac THEN cases tacpx = topq THEN asm rewrite tac[]);

a(cases tacpx = botq THEN asm rewrite tac[]);

a(cases tacpy = xq THEN asm rewrite tac[]);

a(cases tacpy = botq THEN asm rewrite tac[]);

(∗ ∗∗∗ Goal "2 .2" ∗∗∗ ∗)

a(all asm ante tac THEN cases tacpx = topq THEN asm rewrite tac[]);

a(cases tacpx = botq THEN asm rewrite tac[]);

a(cases tacpy = xq THEN asm rewrite tac[]);

a(cases tacpy = botq THEN asm rewrite tac[]);

(∗ ∗∗∗ Goal "2 .3" ∗∗∗ ∗)

a(GET ASM T p¬ top = botq (strip asm tac o conv rule (ONCE MAP C eq sym conv)));

a(DROP NTH ASM T 2 ante tac THEN asm rewrite tac[]);

(∗ ∗∗∗ Goal "2 .4" ∗∗∗ ∗)

a(GET ASM T p¬ top = botq (strip asm tac o conv rule (ONCE MAP C eq sym conv)));

a(DROP NTH ASM T 2 ante tac THEN asm rewrite tac[]);

(∗ ∗∗∗ Goal "2 .5" ∗∗∗ ∗)

a(cases tacpx = topq THEN asm rewrite tac[]);

a(cases tacpx = botq THEN asm rewrite tac[]);

(∗ ∗∗∗ Goal "2 .6" ∗∗∗ ∗)

a(cases tacpy = topq THEN asm rewrite tac[]);

a(cases tacpy = botq THEN asm rewrite tac[]);

(∗ ∗∗∗ Goal "2 .7" ∗∗∗ ∗)

a(POP ASM T ante tac THEN asm rewrite tac[]);

a(cases tacpx = botq THEN asm rewrite tac[]);

a(cases tacpy = xq THEN asm rewrite tac[]);

a(cases tacpy = topq THEN asm rewrite tac[]);

(∗ ∗∗∗ Goal "2 .8" ∗∗∗ ∗)

a(POP ASM T ante tac THEN asm rewrite tac[]);

a(cases tacpx = botq THEN asm rewrite tac[]);

a(cases tacpx = topq THEN asm rewrite tac[]);

a(cases tacpy = xq THEN asm rewrite tac[]);

(∗ ∗∗∗ Goal "2 .9" ∗∗∗ ∗)

a(DROP NTH ASM T 2 ante tac THEN asm rewrite tac[]);

(∗ ∗∗∗ Goal "2 .10" ∗∗∗ ∗)

a(DROP NTH ASM T 2 ante tac THEN asm rewrite tac[]);

a(cases tacpz = topq THEN asm rewrite tac[]);

(∗ ∗∗∗ Goal "2 .11" ∗∗∗ ∗)

a(DROP NTH ASM T 2 ante tac THEN asm rewrite tac[]);

a(cases tacpz = topq THEN asm rewrite tac[]);

save consistency thmp$dominatesq(pop thm());
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Now we retrieve the definition of dominates with the consistency obligation satisfied.

SML

val dominates def = prove rule[get specp$dominatesq]

p∀ x y z • x dominates x

∧ (x dominates y ∧ y dominates x ⇒ x = y)

∧ (x dominates y ∧ y dominates z ⇒ x dominates z )q;

6 CLOSING DOWN

The following ProofPower instruction restores the previous proof context.

SML

pop pc();
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7 THE THEORY fef004

7.1 Parents

cache ′fef fef003

7.2 Children

fef005

7.3 Constants

Num N SET
Ide CHAR LIST SET
I exponent Int → N

I mantissa Int → N

MkInt N → N → Int
F exponent Float → N

F mantissa Float → N

MkFloat N → N → Float
accessDenied N

rowClassTooLow
N

fieldClassOutOfRange
N

noNulls N

nonUniqueValues
N

nonUniformValues
N

ambiguousHaving
N

ambiguousEvaluate
N

noSuchDirectory
N

noSuchTable N

classChange N

downGrade N

underClassified
N

mayNotBeComplete
N

ambiguousUpdate
N

ambiguousColumn
N
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noSuchColumn N

nullValue N

wrongType N

tooTall N

tooWide N

notCleared N

error N

priceless N

sterling N

dinary N

worthless N

ExceptionVal ONE
+ BOOL
+ CHAR LIST
+ Int
+ Float
+ Time
+ Interval
+ Code
+ Class
+ ONE

ClassVal Class
→ ONE

+ BOOL
+ CHAR LIST
+ Int
+ Float
+ Time
+ Interval
+ Code
+ Class
+ ONE

CodeVal Code
→ ONE

+ BOOL
+ CHAR LIST
+ Int
+ Float
+ Time
+ Interval
+ Code
+ Class
+ ONE

IntervalVal Interval
→ ONE

+ BOOL
+ CHAR LIST
+ Int
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+ Float
+ Time
+ Interval
+ Code
+ Class
+ ONE

TimeVal Time
→ ONE

+ BOOL
+ CHAR LIST
+ Int
+ Float
+ Time
+ Interval
+ Code
+ Class
+ ONE

FloatVal Float
→ ONE

+ BOOL
+ CHAR LIST
+ Int
+ Float
+ Time
+ Interval
+ Code
+ Class
+ ONE

IntVal Int
→ ONE

+ BOOL
+ CHAR LIST
+ Int
+ Float
+ Time
+ Interval
+ Code
+ Class
+ ONE

StringVal CHAR LIST
→ ONE

+ BOOL
+ CHAR LIST
+ Int
+ Float
+ Time
+ Interval
+ Code
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+ Class
+ ONE

BoolVal BOOL
→ ONE

+ BOOL
+ CHAR LIST
+ Int
+ Float
+ Time
+ Interval
+ Code
+ Class
+ ONE

VoidVal ONE
+ BOOL
+ CHAR LIST
+ Int
+ Float
+ Time
+ Interval
+ Code
+ Class
+ ONE

VI val ValuedItem
→ ONE

+ BOOL
+ CHAR LIST
+ Int
+ Float
+ Time
+ Interval
+ Code
+ Class
+ ONE

VI worth ValuedItem → N

MkValuedItem N

→ ONE
+ BOOL
+ CHAR LIST
+ Int
+ Float
+ Time
+ Interval
+ Code
+ Class
+ ONE

→ ValuedItem
NullItemItem ONE → ValuedItem + ONE
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ValuedItemItem
ValuedItem → ValuedItem + ONE

Dat item Data → ValuedItem + ONE
Dat class Data → Class
MkData Class → ValuedItem + ONE → Data
DataS Data SET
DataUpdate Data → (ValuedItem + ONE ) + Class + Data
ClassUpdate Class → (ValuedItem + ONE ) + Class + Data
ItemUpdate ValuedItem + ONE → (ValuedItem + ONE ) + Class + Data
isData (ValuedItem + ONE ) + Class + Data → BOOL
isClass (ValuedItem + ONE ) + Class + Data → BOOL
isItem (ValuedItem + ONE ) + Class + Data → BOOL
destData (ValuedItem + ONE ) + Class + Data → Data
destClass (ValuedItem + ONE ) + Class + Data → Class
destItem (ValuedItem + ONE ) + Class + Data → ValuedItem + ONE
CS max ColSpec → Class
CS min ColSpec → Class
CS consGroup ColSpec → N

CS default ColSpec → Data
CS nullType ColSpec → BOOL
CS sterlingType

ColSpec → ONE + ONE + ONE + ONE + ONE + ONE + ONE + ONE
CS dinaryType

ColSpec → ONE + ONE + ONE + ONE + ONE + ONE + ONE + ONE
CS posn ColSpec → N

CS ide ColSpec → CHAR LIST
MkColSpec CHAR LIST

→ N

→ ONE + ONE + ONE + ONE + ONE + ONE + ONE + ONE
→ ONE + ONE + ONE + ONE + ONE + ONE + ONE + ONE
→ BOOL
→ Data
→ N

→ Class
→ Class
→ ColSpec

R group Reference → N

R table Reference → CHAR LIST LIST
MkReference CHAR LIST LIST → N → Reference
CC referential

ColCon → Reference LIST
CC secondary ColCon → BOOL
CC primary ColCon → BOOL
CC classLimited

ColCon → BOOL
CC unique ColCon → BOOL
CC uniform ColCon → BOOL
CC exist ColCon → Class
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MkColCon Class
→ BOOL
→ BOOL
→ BOOL
→ BOOL
→ BOOL
→ Reference LIST
→ ColCon

ColConS ColCon SET
R data Row → (N × Data) SET
R exist Row → Class
MkRow Class → (N × Data) SET → Row
RowS Row SET
TS rows TableSpec → Row LIST
TS cons TableSpec → (N × ColCon) SET
TS colspecs TableSpec → ColSpec SET
TS maxRow TableSpec → Class
TS class TableSpec → Class
MkTableSpec Class

→ Class
→ ColSpec SET
→ (N × ColCon) SET
→ Row LIST
→ TableSpec

TableSpecS TableSpec SET
Dir class Directory → Class
Dir exist Directory → Class
Dir tables Directory → (CHAR LIST × TableSpec) SET
MkDirectory (CHAR LIST × TableSpec) SET → Class → Class → Directory
DirectoryS Directory SET
IdeL CHAR LIST LIST SET
StateS (CHAR LIST LIST × Directory) SET SET
isState (CHAR LIST LIST × Directory) SET → BOOL
isError ′a + ′Error → BOOL
isVal ′a + ′Error → BOOL
destError ′a + ′Error → ′Error
destVal ′a + ′Error → ′a
giveError ′Error → ′a + ′Error
giveVal ′a → ′a + ′Error
SelectEffect Data LIST LIST

→ (CHAR LIST LIST × (N × Data) SET LIST )
+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N

× (N × (ValuedItem + ONE ) + Class + Data)
SET ) SET )

+ Data LIST LIST
UpdateEffect CHAR LIST LIST
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× (N × (N × (ValuedItem + ONE ) + Class + Data) SET )
SET

→ (CHAR LIST LIST × (N × Data) SET LIST )
+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N

× (N × (ValuedItem + ONE ) + Class + Data)
SET ) SET )

+ Data LIST LIST
DeleteEffect CHAR LIST LIST × N SET

→ (CHAR LIST LIST × (N × Data) SET LIST )
+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N

× (N × (ValuedItem + ONE ) + Class + Data)
SET ) SET )

+ Data LIST LIST
InsertEffect CHAR LIST LIST × (N × Data) SET LIST

→ (CHAR LIST LIST × (N × Data) SET LIST )
+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N

× (N × (ValuedItem + ONE ) + Class + Data)
SET ) SET )

+ Data LIST LIST
isSelect (CHAR LIST LIST × (N × Data) SET LIST )

+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N

× (N × (ValuedItem + ONE ) + Class + Data)
SET ) SET )

+ Data LIST LIST
→ BOOL

isUpdate (CHAR LIST LIST × (N × Data) SET LIST )
+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N

× (N × (ValuedItem + ONE ) + Class + Data)
SET ) SET )

+ Data LIST LIST
→ BOOL

isDelete (CHAR LIST LIST × (N × Data) SET LIST )
+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N

× (N × (ValuedItem + ONE ) + Class + Data)
SET ) SET )

+ Data LIST LIST
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→ BOOL
isInsert (CHAR LIST LIST × (N × Data) SET LIST )

+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N

× (N × (ValuedItem + ONE ) + Class + Data)
SET ) SET )

+ Data LIST LIST
→ BOOL

destSelect (CHAR LIST LIST × (N × Data) SET LIST )
+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N

× (N × (ValuedItem + ONE ) + Class + Data)
SET ) SET )

+ Data LIST LIST
→ Data LIST LIST

destUpdate (CHAR LIST LIST × (N × Data) SET LIST )
+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N

× (N × (ValuedItem + ONE ) + Class + Data)
SET ) SET )

+ Data LIST LIST
→ CHAR LIST LIST
× (N × (N × (ValuedItem + ONE ) + Class + Data) SET )
SET

destDelete (CHAR LIST LIST × (N × Data) SET LIST )
+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N

× (N × (ValuedItem + ONE ) + Class + Data)
SET ) SET )

+ Data LIST LIST
→ CHAR LIST LIST × N SET

destInsert (CHAR LIST LIST × (N × Data) SET LIST )
+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N

× (N × (ValuedItem + ONE ) + Class + Data)
SET ) SET )

+ Data LIST LIST
→ CHAR LIST LIST × (N × Data) SET LIST

tabFromEffect
(CHAR LIST LIST × (N × Data) SET LIST )

+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N
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× (N × (ValuedItem + ONE ) + Class + Data)
SET ) SET )

+ Data LIST LIST
→ CHAR LIST LIST

7.4 Aliases

null One : ONE
monolean One : ONE
boolean One : ONE
chars One : ONE
integer One : ONE
floating One : ONE
time One : ONE
interval One : ONE
class One : ONE

7.5 Types

Int
Float
Time
Interval
Code
ValuedItem
Data
ColSpec
Reference
ColCon
Row
TableSpec
Directory
State

7.6 Type Abbreviations

Char CHAR
String CHAR LIST
Num N

Bool BOOL
Ide CHAR LIST
Error N

Worth N

Val ONE
+ BOOL
+ CHAR LIST
+ Int

Page 28 of 39



Lemma 1
DRA FRONT END FILTER PROJECT

Specification of SSQL Semantics I

Ref: DS/FMU/FEF/004
Issue: Revision:4 .3

Date: 5 December 2009

+ Float
+ Time
+ Interval
+ Code
+ Class
+ ONE

NullItem ONE
Item ValuedItem + ONE
Update (ValuedItem + ONE ) + Class + Data
Type ONE + ONE + ONE + ONE + ONE + ONE + ONE + ONE
Errors N LIST
Tab CHAR LIST LIST
StateR (CHAR LIST LIST × Directory) SET
Insert CHAR LIST LIST × (N × Data) SET LIST
Delete CHAR LIST LIST × N SET
UpDate CHAR LIST LIST

× (N × (N × (ValuedItem + ONE ) + Class + Data) SET )
SET

Select Data LIST LIST
Effect (CHAR LIST LIST × (N × Data) SET LIST )

+ (CHAR LIST LIST × N SET )
+ (CHAR LIST LIST
× (N × (N × (ValuedItem + ONE ) + Class + Data) SET )
SET )

+ Data LIST LIST

7.7 Definitions

Num ⊢ Num = Universe
Ide ⊢ Ide = Universe
Int ⊢ ∃ f • TypeDefn (λ x• T ) f
MkInt
I mantissa
I exponent ⊢ ∀ t x1 x2

• I mantissa (MkInt x1 x2 ) = x1
∧ I exponent (MkInt x1 x2 ) = x2
∧ MkInt (I mantissa t) (I exponent t) = t

Float ⊢ ∃ f • TypeDefn (λ x• T ) f
MkFloat
F mantissa
F exponent ⊢ ∀ t x1 x2

• F mantissa (MkFloat x1 x2 ) = x1
∧ F exponent (MkFloat x1 x2 ) = x2
∧ MkFloat (F mantissa t) (F exponent t) = t

error
notCleared
tooWide
tooTall
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wrongType
nullValue
noSuchColumn
ambiguousColumn
ambiguousUpdate
mayNotBeComplete
underClassified
downGrade
classChange
noSuchTable
noSuchDirectory
ambiguousEvaluate
ambiguousHaving
nonUniformValues
nonUniqueValues
noNulls
fieldClassOutOfRange
rowClassTooLow
accessDenied ⊢ error = 1

∧ notCleared = 2
∧ tooWide = 3
∧ tooTall = 4
∧ wrongType = 5
∧ nullValue = 6
∧ noSuchColumn = 7
∧ ambiguousColumn = 8
∧ ambiguousUpdate = 9
∧ mayNotBeComplete = 10
∧ underClassified = 11
∧ downGrade = 12
∧ classChange = 13
∧ noSuchTable = 14
∧ noSuchDirectory = 15
∧ ambiguousEvaluate = 16
∧ ambiguousHaving = 17
∧ nonUniformValues = 18
∧ nonUniqueValues = 19
∧ noNulls = 20
∧ fieldClassOutOfRange = 21
∧ rowClassTooLow = 22
∧ accessDenied = 23

worthless
dinary
sterling
priceless ⊢ worthless = 1

∧ dinary = 2
∧ sterling = 3
∧ priceless = 4
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VoidVal
BoolVal
StringVal
IntVal
FloatVal
TimeVal
IntervalVal
CodeVal
ClassVal
ExceptionVal ⊢ ∀ b s i f t n c cl

• VoidVal = InL null
∧ BoolVal b = InR (InL b)
∧ StringVal s = InR (InR (InL s))
∧ IntVal i = InR (InR (InR (InL i)))
∧ FloatVal f = InR (InR (InR (InR (InL f ))))
∧ TimeVal t = InR (InR (InR (InR (InR (InL t)))))
∧ IntervalVal n

= InR (InR (InR (InR (InR (InR (InL n))))))
∧ CodeVal c

= InR
(InR (InR (InR (InR (InR (InR (InL c)))))))

∧ ClassVal cl
= InR

(InR
(InR

(InR
(InR

(InR
(InR (InR (InL cl))))))))

∧ ExceptionVal
= InR

(InR
(InR

(InR
(InR

(InR
(InR

(InR
(InR null))))))))

ValuedItem ⊢ ∃ f • TypeDefn (λ x• T ) f
MkValuedItem
VI worth
VI val ⊢ ∀ t x1 x2

• VI worth (MkValuedItem x1 x2 ) = x1
∧ VI val (MkValuedItem x1 x2 ) = x2
∧ MkValuedItem (VI worth t) (VI val t) = t

ValuedItemItem
NullItemItem ⊢ ∀ v n
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• ValuedItemItem v = InL v ∧ NullItemItem n = InR n
Data ⊢ ∃ f • TypeDefn (λ x• T ) f
MkData
Dat class
Dat item ⊢ ∀ t x1 x2

• Dat class (MkData x1 x2 ) = x1
∧ Dat item (MkData x1 x2 ) = x2
∧ MkData (Dat class t) (Dat item t) = t

DataS ⊢ DataS = Universe
ItemUpdate
ClassUpdate
DataUpdate ⊢ ∀ i c d

• ItemUpdate i = InL i
∧ ClassUpdate c = InR (InL c)
∧ DataUpdate d = InR (InR d)

isItem
isClass
isData ⊢ ∀ u

• (isItem u ⇔ (∃ i• u = ItemUpdate i))
∧ (isClass u ⇔ (∃ c• u = ClassUpdate c))
∧ (isData u ⇔ (∃ d• u = DataUpdate d))

destItem
destClass
destData ⊢ ConstSpec

(λ (destItem ′, destClass ′, destData ′)
• ∀ i c d
• destItem ′ (ItemUpdate i) = i

∧ destClass ′ (ClassUpdate c) = c
∧ destData ′ (DataUpdate d) = d)

(destItem, destClass, destData)
ColSpec ⊢ ∃ f • TypeDefn (λ x• T ) f
MkColSpec
CS ide
CS posn
CS dinaryType
CS sterlingType
CS nullType
CS default
CS consGroup
CS min
CS max ⊢ ∀ t x1 x2 x3 x4 x5 x6 x7 x8 x9

• CS ide (MkColSpec x1 x2 x3 x4 x5 x6 x7 x8 x9 ) = x1
∧ CS posn (MkColSpec x1 x2 x3 x4 x5 x6 x7 x8 x9 )

= x2
∧ CS dinaryType

(MkColSpec x1 x2 x3 x4 x5 x6 x7 x8 x9 )
= x3

∧ CS sterlingType
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(MkColSpec x1 x2 x3 x4 x5 x6 x7 x8 x9 )
= x4

∧ (CS nullType
(MkColSpec x1 x2 x3 x4 x5 x6 x7 x8 x9 )

⇔ x5 )
∧ CS default

(MkColSpec x1 x2 x3 x4 x5 x6 x7 x8 x9 )
= x6

∧ CS consGroup
(MkColSpec x1 x2 x3 x4 x5 x6 x7 x8 x9 )

= x7
∧ CS min (MkColSpec x1 x2 x3 x4 x5 x6 x7 x8 x9 )

= x8
∧ CS max (MkColSpec x1 x2 x3 x4 x5 x6 x7 x8 x9 )

= x9
∧ MkColSpec

(CS ide t)
(CS posn t)
(CS dinaryType t)
(CS sterlingType t)
(CS nullType t)
(CS default t)
(CS consGroup t)
(CS min t)
(CS max t)

= t
Reference ⊢ ∃ f • TypeDefn (λ x• T ) f
MkReference
R table
R group ⊢ ∀ t x1 x2

• R table (MkReference x1 x2 ) = x1
∧ R group (MkReference x1 x2 ) = x2
∧ MkReference (R table t) (R group t) = t

ColCon ⊢ ∃ f • TypeDefn (λ x• T ) f
MkColCon
CC exist
CC uniform
CC unique
CC classLimited
CC primary
CC secondary
CC referential

⊢ ∀ t x1 x2 x3 x4 x5 x6 x7
• CC exist (MkColCon x1 x2 x3 x4 x5 x6 x7 ) = x1

∧ (CC uniform (MkColCon x1 x2 x3 x4 x5 x6 x7 )
⇔ x2 )

∧ (CC unique (MkColCon x1 x2 x3 x4 x5 x6 x7 )
⇔ x3 )
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∧ (CC classLimited
(MkColCon x1 x2 x3 x4 x5 x6 x7 )

⇔ x4 )
∧ (CC primary (MkColCon x1 x2 x3 x4 x5 x6 x7 )
⇔ x5 )

∧ (CC secondary (MkColCon x1 x2 x3 x4 x5 x6 x7 )
⇔ x6 )

∧ CC referential (MkColCon x1 x2 x3 x4 x5 x6 x7 )
= x7

∧ MkColCon
(CC exist t)
(CC uniform t)
(CC unique t)
(CC classLimited t)
(CC primary t)
(CC secondary t)
(CC referential t)

= t
ColConS ⊢ ColConS = Universe
Row ⊢ ∃ f • TypeDefn (λ x• T ) f
MkRow
R exist
R data ⊢ ∀ t x1 x2

• R exist (MkRow x1 x2 ) = x1
∧ R data (MkRow x1 x2 ) = x2
∧ MkRow (R exist t) (R data t) = t

RowS ⊢ RowS = {r |let data = R data r in data ∈ Num 7→ DataS}
TableSpec ⊢ ∃ f • TypeDefn (λ x• T ) f
MkTableSpec
TS class
TS maxRow
TS colspecs
TS cons
TS rows ⊢ ∀ t x1 x2 x3 x4 x5

• TS class (MkTableSpec x1 x2 x3 x4 x5 ) = x1
∧ TS maxRow (MkTableSpec x1 x2 x3 x4 x5 ) = x2
∧ TS colspecs (MkTableSpec x1 x2 x3 x4 x5 ) = x3
∧ TS cons (MkTableSpec x1 x2 x3 x4 x5 ) = x4
∧ TS rows (MkTableSpec x1 x2 x3 x4 x5 ) = x5
∧ MkTableSpec

(TS class t)
(TS maxRow t)
(TS colspecs t)
(TS cons t)
(TS rows t)

= t
TableSpecS ⊢ TableSpecS

= {ts
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|let cns = TS cons ts and rows = TS rows ts
in cns ∈ Num 7→ ColConS
∧ (∀ r• r ∈l rows ⇒ r ∈ RowS )}

Directory ⊢ ∃ f • TypeDefn (λ x• T ) f
MkDirectory
Dir tables
Dir exist
Dir class ⊢ ∀ t x1 x2 x3

• Dir tables (MkDirectory x1 x2 x3 ) = x1
∧ Dir exist (MkDirectory x1 x2 x3 ) = x2
∧ Dir class (MkDirectory x1 x2 x3 ) = x3
∧ MkDirectory

(Dir tables t)
(Dir exist t)
(Dir class t)

= t
DirectoryS ⊢ DirectoryS = {d |Dir tables d ∈ Ide 7→ TableSpecS}
IdeL ⊢ IdeL = Universe
StateS ⊢ StateS = IdeL 7→ DirectoryS
isState ⊢ ∀ s• isState s ⇔ s ∈ StateS
state type def

⊢ ∃ f • TypeDefn isState f
giveVal
giveError
destVal
destError
isVal
isError ⊢ ConstSpec

(λ
(giveVal ′, giveError ′, destVal ′, destError ′,

isVal ′, isError ′)
• ∀ v e ve
• giveVal ′ v = InL v

∧ giveError ′ e = InR e
∧ destVal ′ (giveVal ′ v) = v
∧ destError ′ (giveError ′ e) = e
∧ (isVal ′ ve ⇔ (∃ v1• ve = giveVal ′ v1 ))
∧ (isError ′ ve
⇔ (∃ e1• ve = giveError ′ e1 )))

(giveVal , giveError , destVal , destError , isVal ,
isError)

InsertEffect
DeleteEffect
UpdateEffect
SelectEffect ⊢ ∀ i d u s

• InsertEffect i = InL i
∧ DeleteEffect d = InR (InL d)
∧ UpdateEffect u = InR (InR (InL u))
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∧ SelectEffect s = InR (InR (InR s))
isInsert
isDelete
isUpdate
isSelect ⊢ ∀ e

• (isInsert e ⇔ (∃ i• e = InsertEffect i))
∧ (isDelete e ⇔ (∃ d• e = DeleteEffect d))
∧ (isUpdate e ⇔ (∃ u• e = UpdateEffect u))
∧ (isSelect e ⇔ (∃ s• e = SelectEffect s))

destInsert
destDelete
destUpdate
destSelect ⊢ ConstSpec

(λ
(destInsert ′, destDelete ′, destUpdate ′,

destSelect ′)
• ∀ i d u s
• destInsert ′ (InsertEffect i) = i

∧ destDelete ′ (DeleteEffect d) = d
∧ destUpdate ′ (UpdateEffect u) = u
∧ destSelect ′ (SelectEffect s) = s)

(destInsert , destDelete, destUpdate, destSelect)
tabFromEffect

⊢ ConstSpec
(λ tabFromEffect ′

• ∀ i d u
• tabFromEffect ′ (InsertEffect i) = Fst i

∧ tabFromEffect ′ (DeleteEffect d) = Fst d
∧ tabFromEffect ′ (UpdateEffect u) = Fst u)

tabFromEffect

7.8 Theorems

dominates consistent
lattice bottom consistent
lattice top consistent
lub consistent
glb consistent

⊢ Consistent
(λ

(dominates ′, lattice bottom ′, lattice top ′,

lub′, glb ′)
• ∀ x y z
• dominates ′ x x

∧ (dominates ′ x y ∧ dominates ′ y x ⇒ x = y)
∧ (dominates ′ x y ∧ dominates ′ y z
⇒ dominates ′ x z )

∧ (∀ x• dominates ′ x lattice bottom ′)
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∧ (∀ x• dominates ′ lattice top ′ x )
∧ (∀ x y z
• dominates ′ (lub′ x y) x

∧ dominates ′ (lub′ x y) y
∧ (dominates ′ z x ∧ dominates ′ z y
⇒ dominates ′ z (lub′ x y)))

∧ (∀ x y z
• dominates ′ x (glb ′ x y)

∧ dominates ′ y (glb ′ x y)
∧ (dominates ′ x z ∧ dominates ′ y z
⇒ dominates ′ (glb ′ x y) z )))
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